[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Emacs-diffs] master 4e23cd0 4/5: * mail/rmail.el (rmail-show-messag

From: Steinar Bang
Subject: Re: [Emacs-diffs] master 4e23cd0 4/5: * mail/rmail.el (rmail-show-message-1): When displaying a mime message,
Date: Tue, 14 Apr 2015 23:47:02 +0200
User-agent: Gnus/5.130012 (Ma Gnus v0.12) Emacs/24.4 (windows-nt)

>>>>> Alan Mackenzie <address@hidden>:

> I don't know.  But when it has happened to me, it has always been with
> existing files in a repository directly cloned from a remote
> repository.  (I have no experience of other scenarios.)  I can't even
> say whether the loss of staging of files is a bug or an intended
> feature.

I tried an experiment today, and I succeeded in reproducing it (in an
attempt at disproving it), but I didn't succeed in an attempt at
reproducing it with a slightly simpler procedure.

If I can reproduce it reliably I will file a bug with git.

I ended up with the restored stashed file being empty. 

See the conflict at the end of the commands below:

address@hidden:~/git/git-pull-test$ git pull
Auto-merging foo
Merge made by the 'recursive' strategy.
 foo | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
address@hidden:~/git/git-pull-test$ git stash pop
Auto-merging foo
CONFLICT (content): Merge conflict in foo
address@hidden:~/git/git-pull-test$ cat foo
<<<<<<< Updated upstream
hi there
line two
line three modified
is there more?
Here is more!
Less is more!
>>>>>>> Stashed changes
address@hidden:~/git/git-pull-test$ git --version
git version 1.9.4.msysgit.1

(what I did was to create a local git repository, clone it to another
local repository and try to pull at the same time as having stashed
changes in a modified file in the cloned repository)

However, this has never happened to me in a real situation, and I was
unable to reproduce it when I tried again (but with a slightly simpler

reply via email to

[Prev in Thread] Current Thread [Next in Thread]