[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

yes-or-no-p prompt conditionally broken in master?

From: Kaushal Modi
Subject: yes-or-no-p prompt conditionally broken in master?
Date: Thu, 03 Sep 2015 16:31:23 +0000

Hi all,

I tend to keep my e
macs build updated with the master every few days.

My last build was 2 days back at this commit: http://git.savannah.gnu.org/cgit/emacs.git/commit/?id=a3c31adea4970b8a7fc7f495e6a6a6d4a93e69ce and everything worked fine.

- When on latest master, for ANY yes-or-no-p prompt, for the first prompt I cannot see the prompt question. At times, all I see is the cursor at the very left in the minibuffer. At times, I see no cursor and have to assume that the minibuffer is in focus. I blindly need to hit y or n to proceed (for example when quitting emacs). Some times, 2nd prompt onwards the prompt questions start appearing fine.
- This issue goes away if I revert to the above linked commit with my emacs config.
- This issue also goes away in an emacs -Q session while on the latest commit on master.

Below are all the commits after that commit that works for me.
So some package I have installed is clashing with one of the below commits.

I tried debugging but cannot narrow down to the problem. Can one of the authors would know if their commit could have possibly changed how yes-or-know-p prompt display behaved? A proper direction will help me debug the problem faster.

| Dmitry Gutov    | vc-git-mode-line-string: Explicitly re-apply the faceHEADmaster  |
| Paul Eggert     | Treat initial-scratch-message as a doc string                    |
| Paul Eggert     | Fix describe-char bug with glyphs on terminals                   |
| Paul Eggert     | Follow text-quoting-style in display table init                  |
| K. Handa        | Fix typo                                                         |
| K. Handa        | Merge branch 'master' of git.sv.gnu.org:/srv/git/emacs           |
| K. Handa        | fix previous change                                              |
| David Caldwell  | * lisp/vc/vc-hooks.el (vc-refresh-state): New command            |
| Paul Eggert     | Escape ` and ' in doc                                            |
| Stefan Monnier  | Generalize the prefix-command machinery of C-u                   |
| Paul Eggert     | Rework quoting in tutorial                                       |
| Paul Eggert     | Setup quote display only if interactive                          |
| Katsumi Yamaoka | Use defalias at the top level                                    |
| Paul Eggert     | terminal-init-w32console mimicks command-line                    |
| Paul Eggert     | Display replacement quotes with shadow glyphs                    |
| Michael Albinus | * lisp/net/tramp-sh.el (tramp-methods) <sudo>: Mask "Password:". |

PS: One of the packages I have installed is http://elpa.gnu.org/packages/minibuffer-line.html and I thought that that might be causing the problem. But disabling that did not fix this.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]