[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

strange error from global-ede-mode

From: Stephen Leake
Subject: strange error from global-ede-mode
Date: Thu, 10 Sep 2015 14:52:17 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (windows-nt)

I'm getting an error from something in ede when I move an elisp buffer
to a new frame.

>From Emacs master -Q on Windows (built with mingw64):

    (require 'other-frame-window)
    (other-frame-window-mode t)
    (require 'ede)
    (require 'ede/emacs)
    (global-ede-mode 1) ;; not just single-buffer ede-minor-mode
    (find-file (locate-file "ede/files.el" load-path))

Then invoke 'C-x F'; this gives an error message starting with

"(wrong-type-argument (or eieio-object class) [cl-struct-eieio--class

The elisp file has to be in the Emacs core source directory, so EDE
detects the Emacs project. I get the same error from a C file in Emacs
core source.

Invoking C-x F when there is another frame does not give the error.

Killing the new frame and then running C-x F in files.el repeats the

Enabling debug-on-error does not catch the error.

Enabling edebug in ofw-move-to-other-frame and stepping thru isolates
the error to x-create-frame in w32fns.c. I haven't tried debugging at
the C level yet, nor running on Linux. I'll try those next.

The error only happens with global-ede-mode enabled. So I'm guessing it
has something to do with running ede-minor-mode in a new buffer. But I
don't think ofw-move-to-other-frame creates a new buffer, so I don't see
why that matters.

Any other ideas for pinning this down?

-- Stephe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]