[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ELPA policy

From: Stephen Leake
Subject: Re: ELPA policy
Date: Tue, 17 Nov 2015 10:18:40 -0600
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (windows-nt)

Filipp Gunbin <address@hidden> writes:

>> So if emacs 25 contains a core ELPA package seq.el 1.0, the declaration
>> ;; Package-Requires: ((emacs "25.1"))
>> is equivalent to:
>> ;; Package-Requires: ((emacs "25.1") (seq "1.0))
>> If seq.el 1.1 is later released via the Gnu ELPA server, it will be used
>> in either case.
> Will the user have the option to continue to use the tarball version
> instead of newer ELPA version?  

Yes, they may install it or not; my statement above assumed the ELPA
package was installed and updated.

> Or choosing which ELPA version to use?

Technically, there is only one ELPA version; the one shown by
`list-packages'. However, after user installs one version, they may opt
to not install an update.

If they delete the installed version, they can only install the latest

That's all just using the commands in package.el; users can of course
save code and copy it into and out of `load-path' manually.

> This may be needed when she uses previous major Emacs release, and
> current ELPA package version requires newer core APIs.

If there is a compatible ELPA package version that is more recent than
the version bundled with that Emacs version, but older than the latest
ELPA version, yes.

But that's not supported by the current ELPA server and package.el.

So at the moment, users of older Emacsen are stuck with either the
bundled package, or the latest package.

The maintainer of the ELPA package can provide compatibility code so it
is useful with older Emacsen. But that gets harder the farther back you
go; my current limit is 24.3.

-- Stephe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]