[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Please add comments to isearch.el

From: Juri Linkov
Subject: Re: Please add comments to isearch.el
Date: Mon, 14 Dec 2015 02:16:31 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (x86_64-pc-linux-gnu)

> On 12 Dec 2015 11:27 pm, "Juri Linkov" <address@hidden> wrote:
>> 1. Rename ‘lax’ to ‘lax-boundary’ to distinguish between lax at the
> word/symbol
>>    boundary and lax-whitespace to avoid confusion, so rename the
>>    arg ‘lax’ to ‘lax-boundary’ in all regexp-producing functions,
>>    isearch--lax-regexp-function-p to
>>    isearch--lax-boundary-regexp-function-p, etc.
> +1
>> 2. Try to find a better common naming scheme used for the
>>    regexp-producing functions word-search-regexp, isearch-symbol-regexp,
>>    character-fold-to-regexp.
> I think the first two shouldn't even be in isearch.el. There's a ton of
> stuff in isearch.el that's just generally useful in searches (nothing
> specific to incremental search), and should be moved to some search.el
> file.

Yes, everything with the prefix ‘search-’ in isearch.el
(as well as occur commands in replace.el) are here for historical reasons.

>> 3. Use well established terminology that shortens the prefixes
>>    of character-related functions to just char- to use char-fold.
>>    ‘C-h f char TAB’ or ‘C-h v char TAB’ shows the standard
>>    Emacs naming convention.
>> 4. Use the upper-case standard name “Unicode” in the documentation.

Ohh, and I'd add also search-default-regexp-mode -> 
that currently causes confusion due to its similarity with 

> I don't see what these have to do with the readability of isearch el, but
> by all means, feel free to do these.

Maybe better to wait for establishing of regular merges from emacs-25 to
master, because I'm afraid that renaming character-fold.el to char-fold.el
now might cause merge conflicts on the first such merge.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]