[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs-25 build broken?

From: Angelo Graziosi
Subject: Re: emacs-25 build broken?
Date: Thu, 24 Dec 2015 01:07:57 +0100
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Thunderbird/38.4.0

Ok. I tried the build also on GNU/Linux (Mint 17.3), a GTK build with clang, and current 25 branch fails to build in the same manner I described in this thread. So the issue is not MSYS2/MINGW64 specific.

So I tried a sort of "binary" search to find when the build was broken..

I tried with this source:


from this commit:

Tom Tromey: Fix bug #18588 by making bug-reference-bug-regexp more lenient

and it builds fine!

Thentried the next commit:


Anders Lindgren: File-name completion of non-ASCII characters on OS X (bug#22169)

and it failed as described...

Definitively Emacs-25 branch is broken, at leas on MSYS2/MinGW64 and GNU/Linux Mint 17.3

But.. have you tried to build in a virgin source tree? For example with a tarball from http://git.savannah.gnu.org/cgit/emacs.git/snapshot or in a just git cloned repo:

git clone -b emacs-25 git://git.sv.gnu.org/emacs.git



Il 23/12/2015 19:27, Anders Lindgren ha scritto:

I'm glad that you managed to get the build up and running.

Sending me a CC was fine, as I just pushed a change related to
ucs-normalize, even though it (luckily) wasn't the culprit.

     -- Anders

On Wed, Dec 23, 2015 at 6:17 PM, Kaushal Modi <address@hidden>

Why him?  I don't see any changes he made in ucs-normalize.el.  Do you?

Sorry, I saw that that commit by Anders added the (require 'ucs-normalize)
and thought that this error was related to that. I just rebuilt using that
commit and the build finished fine.

Does reverting 0905307 solves the problem?

Actually I just finished building using make bootstrap from the lastest
commit on emacs-25 and it finished fine.

Please ignore this ping, Anders.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]