[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Emacs-diffs] emacs-25 f8208b6: Document the user-level features of

From: Eli Zaretskii
Subject: Re: [Emacs-diffs] emacs-25 f8208b6: Document the user-level features of the Xref package
Date: Mon, 25 Jan 2016 22:52:42 +0200

> Cc: address@hidden
> From: Ken Brown <address@hidden>
> Date: Mon, 25 Jan 2016 15:38:58 -0500
> First, paragraph b of the Xref info node talks about etags, with a 
> reference to the subnode on creating tags tables.  It would have helped 
> me if there had been a further sentence saying that a user has to give 
> the command M-x visit-tags-table before Xref will use etags as the 
> backend.

That's not true, you don't need to invoke visit-tags-table manually.
Xref does that automatically (it asks you for confirmation).
Something isn't working correctly in your case.

> Second, I suggest that Xref should offer to use etags as the backend 
> when a TAGS file exists in the current directory.

It already does, at least in C mode.

> I had the following experience in my first attempt to use Xref:
> After reading the Xref node and glancing at the "Creating Tags Tables" 
> node, I remembered that there was a 'tags' target in the top level 
> Makefile of the emacs tree, so I gave the command 'make tags' to create 
> the TAGS files.  Then I visited a C file in the src directory and tried 
> 'M-.' on an identifier.  The result was the error message 'Symbol’s 
> function definition is void: etags--xref-backend'.  I didn't know what 
> to do with that message, so I went back to the Xref node to see if it 
> would tell me how to tell Xref to use etags as backend.  It didn't, but 
> I finally tried M-x visit-tags-table, and it worked.

Very strange.  Do you have a TAGS file in the src directory?  You
should if you invoked "make TAGS" at top level.

If I visit some C file in src/ and type M-. I'm asked to confirm to
visit tags table in src, and then I'm presented with the definition of
the identifier (or with an *xref* buffer if there are more than one
candidate).  So there's some factor at work in your case that somehow
prevents this from working correctly.

Did you try the same in a .el file?  What happened?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]