[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacsclient in 25 branch: error opening any file

From: Joseph Mingrone
Subject: Re: emacsclient in 25 branch: error opening any file
Date: Sun, 05 Jun 2016 02:32:45 -0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.94 (berkeley-unix)

Eli Zaretskii <address@hidden> writes:

>> From: Joseph Mingrone <address@hidden> Date: Wed, 01 Jun 2016 16:10:49 -0300

>> After starting an Emacs daemon, everything works as expected, but after some
>> time (or event I'm unaware of), trying to open a file from a shell gives an
>> error.

>> % emacsclient some_file Waiting for Emacs...  *ERROR*: Wrong type argument:
>> stringp, nil

> Please try to figure out which Emacs function signals this error.

I managed to trigger the issue again today.  I tried instrumenting various
functions in server.el and was able to enter the function server-add-client
before the error was displayed at the terminal.  I know the error occurs
somewhere inside the add-to-list call, but I foolishly killed the frame before I
was clear on the exact error.  After closing the frame, the debugger wouldn't
stop in server-add-client.

Andrés Ramírez <address@hidden> writes:
> Does 'emacsclient -c -t' works for You?

Same error.

Another issue (or my misunderstanding)...

% emacs -Q --daemon (setq server-log t)
% emacsclient -nc some_file.txt

No matter what client/server activity I try, no *server* buffer is created.
Instrumenting server-log shows that the function is being called and the (when
server-log... is true.

I'll write more when I know more.


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]