[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Recent change in master breaks async package update using paradox

From: Kaushal Modi
Subject: Re: Recent change in master breaks async package update using paradox
Date: Thu, 06 Apr 2017 10:46:51 +0000

On Thu, Apr 6, 2017, 1:00 AM Lars Brinkhoff <address@hidden> wrote:
Kaushal Modi <address@hidden> writes:
> I deleted the .elc files, restarted emacs and tried again and still
> get the same error (only when updating/installing packages
> asynchronously).

You could also try a full "make bootstrap".

I did not confirm but I thought that should have happened because I did rebuild emacs with `make bootstrap`.

There was no option because before `make bootstrap`, I got:

Loading emacs-lisp/timer...
Loading isearch...
Attempt to autoload cl-old-struct-compat-mode while preparing to dump
make[1]: *** [emacs] Error 255
make[1]: Leaving directory `/home/kmodi/downloads/git/emacs/src'
make: *** [src] Error 2

Could you please tell me the exact steps you did to get the error?
I'd like to try to reproduce it myself.

- Install paradox from GNU Elpa
- (paradox-enable)
- M-x list-packages (This will now open the default package manager, but with additions made by paradox).
- Install any package ( i x ), and then hit 'y' when asked if you want to do that asynchronously. 
- You will then see the error I mentioned in my first email of this thread. 

I will open a bug report for this today so that all this info can be contained in there.  

Kaushal Modi

reply via email to

[Prev in Thread] Current Thread [Next in Thread]