[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latest git sources fail to compile w/gnutls on debian stable

From: Harry Putnam
Subject: Re: Latest git sources fail to compile w/gnutls on debian stable
Date: Sun, 30 Apr 2017 19:19:54 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1 (gnu/linux)

Paul Eggert <address@hidden> writes:

> To be honest I'm not sure I would mess with this stuff if you're not
> an expert. I.e., if you want to run more-bleeding-edge software, by
> far the easiest way to do that is to upgrade to a more-bleeding-edge
> version of Debian.

No doubt wise.

I've compiled emacs periodically for probably something like 10 yrs
and have always been able to to get it done... sometimes with help
here or gmane.emacs.help.  I guess its become a habit.

Its only this latest version that will not fetch imap groups when
compiled with --with-gnutls=no earlier versions of 26 did so ok.

When it was working I would see something about gnutls-cli when
fetching imap groups.  But this latest version is not able to do that
apparently and does not fetch imap when compiled --with-gnutls=no

> That being said, the Debian package list doesn't list any
> "libgnutls-dev" package for jessie, which is the current Debian
> stable. That is, https://packages.debian.org/jessie/libgnutls-dev
> reports an error. If you are getting libgnutls-dev from some source
> other than Debian, that might explain the problem - but then, this
> would not match your desire to run a stable version, so I am puzzled
> as to what your system's state is. You might want to audit
> /etc/apt/sources.list before proceeding.
>>    libgnutls-dev : Depends: libgnutls-openssl27 (= 2.12.20-8+deb7u5) but 
>> 3.3.8-6+deb8u4 is installed.

Aha... I see.

> jessie's libgnutls-openssl27 is indeed 3.3.8-6+deb8u4 currently; at
> least, that's what
> https://packages.debian.org/jessie/libgnutls-openssl27
> says. 2.12.20-8+deb7u5 is for wheezy, which is the obsolete stable
> release. Perhaps you installed some wheezy packages atop a jessie
> system a while ago? or are trying to do the reverse? I'm not sure I'd
> recommend that....

I had wheezy on sources list to get encfs which is considered broken
since wheezy.. And so not available on jessie, Apparently wheezy has
been on sources.list ever since... some months now.  No telling how
badly I've mangled my nice stable install.

(This is the first time I've tried to keep my debian OS on
stable... always used testing until a few months ago)

First off, removed the `wheezy' entries from sources.list.

I first thought to `aptitude remove' any offending wheezy packages ...
but after I thought a bit, I'm pretty sure that would end in some kind of

Finally, with wheezy removed .. and aptitude update completed I tried
aptitude install gnutls to see what would be dredged up.

That led to libgnutls28-dev... once I installed that the compile
worked just fine.

I guess when I saw the gnutls-dev wheezy package.. saying `dev' I
didn't notice ... libgnutls28-dev

Thanks for doing the work and pointing out the problem.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]