[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: org-copy-visible does not work with x-select-enable-primary

From: Alain . Cochard
Subject: Re: org-copy-visible does not work with x-select-enable-primary
Date: Mon, 10 Sep 2018 17:20:45 +0200

Hi, and thanks for the feedback.

Eli Zaretskii writes on Mon 10 Sep 2018 17:49:

 > It will yank only "* foo" if you move the cursor in the Org buffer
 > before yanking, or do anything else that removes the selection
 > (i.e. removes the highlight due to selecting text).

Are you sure??  For me and all the configurations tried (emacs and org
versions), when x-select-enable-primary is true, it does not simply
yank "* foo", even after I remove the selection.

The already mentioned tests I made were on my laptop.  I just tried on
2 different machines, with, respectively, those configurations:

Emacs : GNU Emacs 25.3.1 (x86_64-redhat-linux-gnu, GTK+ Version
3.22.19) of 2017-09-15 Package: Org-mode version 8.2.10
(release_8.2.10 @ /usr/share/emacs/25.3/lisp/org/)

GNU Emacs 23.1.1 (x86_64-redhat-linux-gnu, GTK+ Version 2.24.23) of
2015-02-19 on c6b8.bsys.dev.centos.org Org-mode version 6.21b

and the bad behavior is identical -- removing the selection does not
help.   All the machines are redhat based, though... Could it be that
you used a completely different distribution?

(NB: With x-select-enable-primary false --default--, it yanks "* foo"
whether I remove the selection or not.)

EOST (École et Observatoire des Sciences de la Terre) 
IPG (Institut de Physique du Globe) | address@hidden
5 rue René Descartes   [bureau 106] | Phone: +33 (0)3 68 85 50 44 
F-67084 Strasbourg Cedex, France    | Fax:   +33 (0)3 68 85 01 25     

reply via email to

[Prev in Thread] Current Thread [Next in Thread]