[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: branch master segfault (2019-02-05)

From: Eli Zaretskii
Subject: Re: branch master segfault (2019-02-05)
Date: Tue, 05 Feb 2019 18:50:57 +0200

> From: Philippe Vaucher <address@hidden>
> Date: Tue, 5 Feb 2019 15:48:20 +0100
> Since a while, the docker images from "master" segfault:
> ```
> address@hidden:~$ docker run -it --rm silex/emacs:master
> Fatal error 11: Segmentation fault
> Backtrace:
> emacs(+0x132cae)[0x555966f19cae]
> emacs(+0x11925a)[0x555966f0025a]
> emacs(+0x13107e)[0x555966f1807e]
> emacs(+0x131328)[0x555966f18328]
> emacs(+0x1313ac)[0x555966f183ac]
> /lib/x86_64-linux-gnu/libpthread.so.0(+0x12890)[0x7f3010977890]
> ```
> The binary is semi-working tho, like for example:
> ```
> address@hidden:~$ docker run -it --rm silex/emacs:master emacs --version
> GNU Emacs 27.0.50
> Copyright (C) 2019 Free Software Foundation, Inc.
> You may redistribute copies of GNU Emacs
> under the terms of the GNU General Public License.
> For more information about these matters, see the file named COPYING.
> ```
> Here attached you'll find the gdb trace and a strace log. I tried to build 
> the image with debug flags using what's
> in DEBUG, but the errors are similar.
> I know that recently the portable dumper branch was merged, I suspect it has 
> to do with the segfault... If
> necessary, I can bisect to find the offending commit, but I was hoping 
> someone would quickly know what is
> happening.
> This happens even if I run the container in privileged mode.

Thanks.  Could you please show the Lisp backtrace as well, using the
"xbacktrace" command defined on src/.gdbinit?

Also, does this happen when Emacs is invoked as "emacs -Q"?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]