[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make check fails to link due to missing -lpthread?

From: Paul Eggert
Subject: Re: make check fails to link due to missing -lpthread?
Date: Fri, 3 May 2019 16:18:36 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1

On 5/3/19 9:07 AM, Jeffrey Walton wrote:
> 'make check' fails to link on Fedora:
> gcc -Demacs  -I. -I. -I../lib -I../lib                     -MMD -MF
> deps/.d -MP       -g2 -O2 -march=native -fPIC  -Wl,-znocombreloc
> -no-pie -L/usr/local/lib64 -Wl,-R,/usr/local/lib64
> -Wl,--enable-new-dtags \
>   -o temacs   ...

The dependencies on /usr/local means it'll be hard for others to
reproduce the problem. Although you didn't mention which Emacs version
you built, or which Fedora version and hardware platform you were using,
I tried to reproduce the problem with the latest releases (Emacs 26.2,
Fedora 30) on x86-64 (AMD Phenom II X4 910e), as shown in the attached
build transcript. It worked for me.

> I suspect Emacs is creating
> makefiles after configure so they can't be patched.
I don't think this suspicion is correct.

If you're going to hack on makefiles after 'configure' has generated
them, I'm afraid you'll need to go to the effort of debugging problems
that occur if the hacked makefiles fail.

Attachment: build-log.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]