[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs's set-frame-size can not work well with gnome-shell?

From: Dmitry Gutov
Subject: Re: Emacs's set-frame-size can not work well with gnome-shell?
Date: Tue, 21 Jan 2020 02:02:37 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

On 20.01.2020 18:57, martin rudalics wrote:
 > https://github.com/tumashu/company-posframe/issues/2
 > Mutter is singled out as a cause, HiDPI or not.

OK.  Has anyone tried with a non-GTK build so we can exclude GTK
dependencies too?  Has anyone tried with NS (here GNUstep doesn't even
build at the moment)?

GNUstep what? I'm hesitant to install the dependencies, whatever they are.

Still, a good question. I did a Lucid toolkit build and, lo and behold, the bug went away. Also it's blazing fast:

(benchmark 200 '(resize-test test-frame))
=> 0.007s

One more thing to try.  In x_wm_set_size_hint we don't set size hints
for child windows here (around line 1404 of gtkutil.c):

   if (NILP (Vafter_init_time)
       || FRAME_PARENT_FRAME (f))

I forgot why, maybe it broke something or caused some weird behavior.  I
should have had a reason back then and forgot to comment it.

Replace that with

   if (NILP (Vafter_init_time)
       || !FRAME_GTK_OUTER_WIDGET (f))
/**       || FRAME_PARENT_FRAME (f)) **/

and rebuild (it builds and runs without problems here).  Make sure to
run with 'frame-resize-pixelwise' t.  To the best of my knowledge we do
set size hints for non-GTK builds ...

That didn't help, however. With either value of frame-resize-pixelwise.

Did 'make bootstrap', to make doubly sure.

 > Should we start commenting on that issue?

Politely so, yes.  Always keep in mind that our way of using GTK is a
peculiar one and that child frames are a somewhat underdeveloped issue,
mostly used for modal dialogues, centered on their parent, never
changing size and the like.


It appears that they work okay in other desktop environments, though. It might also turn out to be a GTK problem.

FTR, my GTK version is 3.24.8.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]