>> we could probably rename some existing
>> functions to use the `string-` prefix
> We have both 'match-string' and 'string-match', which do different
> things. Any particular ideas for renaming?
I'm not sure `match-string` qualifies as
a string-manipulating function. Maybe it belongs in a "regexp-matching"
I agree. What would be the most logical is to move the regexp related functions to the regexp- namespace no?
string-match would be aliased as regexp-match, match-string as regexp-match-value, etc.