[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error when building from master branch

From: Kaushal Modi
Subject: Re: Error when building from master branch
Date: Sun, 26 Jul 2020 21:26:32 -0400

On Sun, Jul 12, 2020 at 2:36 PM Paul Eggert <eggert@cs.ucla.edu> wrote:
On 7/12/20 10:48 AM, Kaushal Modi wrote:

> emacsgtkfixed.c: In function ‘emacs_fixed_get_type’:
> emacsgtkfixed.c:51:1: error: size of array
> ‘_GStaticAssertCompileTimeAssertion_3’ is negative
>     51 | G_DEFINE_TYPE (EmacsFixed, emacs_fixed, GTK_TYPE_FIXED)
>        | ^~~~~~~~~~~~~

I'm not seeing the problem on Fedora 31.

My guess is that your pkg-config setup doesn't match your libraries. This sort
of thing can be a pain to debug. Possibly you can work around the problem by
setting PKG_CONFIG_LIBDIR in your environment.

Hello Paul,

Sorry for the late reply. I was waiting to find some time so that I could do a deep-dive into this issue.

I spent few hours on this today, but couldn't get emacs to build on CentOS 7. I tried with the default pkg-config 0.27.1. That failed with the same error.

Then I installed pkg-config 0.28.0 (which worked well for me on RHEL 6.8), but the same error using that.

And then the same thing with pkg-config 0.29.2 as well.

I also tried out your suggestion to set the env var PKG_CONFIG_LIBDIR. I set it with the same value of my default PKG_CONFIG_DIR that contains the paths of all the necessary pkgconfig dirs (I hope that is the right value to set for PKG_CONFIG_LIBDIR). But still couldn't get past this error.

What does that G_DEFINE_TYPE check do in emacsgtkfixed.c? Is there some local hack I can do to that .c file so that I can get past this error?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]