[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [feature/rcirc-update] Reconnects don't seem to work anymore

From: Philip Kaludercic
Subject: Re: [feature/rcirc-update] Reconnects don't seem to work anymore
Date: Tue, 15 Jun 2021 16:17:56 +0000

Tassilo Horn <tsdh@gnu.org> writes:

> Tassilo Horn <tsdh@gnu.org> writes:
>> I'm now restarting emacs.  The next time I get a disconnect, I'll try
>> /reconnect instead.
> I got disconnected from freenode, and this time I've tried /reconnect
> instead of `M-x rcirc RET'.  However, that reconnected to the server but
> again all channel buffers still show rcirc:disconnected.  The
> `rcirc-buffer-alist' in the server buffer for freenode is still
> populated with the right buffers as previously.

I am still not able to consistently reproduce this issue. Just to be
sure, what commit are you on?

> Also, after /reconnect it seems I got an error during nickserv
> authentication as configured by `rcirc-authinfo':
>   (setq rcirc-authinfo
>         `(("freenode" nickserv ,rcirc-default-nick 
> ,th/nickserv-password-freenode)
>           ("libera"   nickserv ,rcirc-default-nick 
> ,th/nickserv-password-liberachat)
>           ("oftc"     nickserv ,rcirc-default-nick ,th/nickserv-password-oftc)
>           ("gnome"    nickserv "tsdh80"            
> ,th/nickserv-password-gnome)))
> The error was:
> 06:58 -*.freenode.net- *** You are connected to chat.freenode.net using TLS
>                        (SSL) cipher 'TLSv1.3-TLS_AES_256_GCM_SHA384'
> 06:58 !!! "@msgid=446~1623712485~22272;inspircd.org/service;inspircd.org/bot
>           :NickServ!services@services.freenode.net NOTICE tsdh :Nick tsdh
>           isn't registered." (wrong-type-argument arrayp nil)

>From your other message, it seems like this is specificity related to
freenode, right?

> Bye,
> Tassilo

        Philip K.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]