[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs-28 build failure - gnulib

From: Paul Eggert
Subject: Re: emacs-28 build failure - gnulib
Date: Tue, 5 Oct 2021 11:24:54 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.13.0

On 10/5/21 9:53 AM, Andrea Corallo wrote:
I'm getting this error with:

git clean -xfd && ./autogen.sh && ./configure --without-x --without-native-compilation  
&& time make bootstrap -j16

Unfortunately 'git clean -xfd' doesn't necessarily clean out all the detritus. I just now tried the following on Fedora 34 x86-64 from a fresh Git checkout (current emacs-28 commit, namely 1cd1b2835b5e35562c677c48dcf185bb73af4275):

./autogen.sh && ./configure --without-x --without-native-compilation && time make bootstrap -j16

and it worked for me (compressed build log attached). Please try this approach. If it works for you, it would suggest that 'make bootstrap' has a bug in that it doesn't clean out enough stuff somewhere.

I built on a circa-2010 machine (AMD Phenom II X4 910e) with only 4 CPUs. It's possible that my machine's lack of parallelism helped, though if that's the case it would indicate a missing dependency in a Makefile somewhere.

Attachment: build-log.txt.gz
Description: application/gzip

reply via email to

[Prev in Thread] Current Thread [Next in Thread]