[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Remove all existing file notification watches from Emacs

From: Stefan Kangas
Subject: Re: Remove all existing file notification watches from Emacs
Date: Sat, 16 Oct 2021 16:32:41 +0200

Stefan Monnier <monnier@iro.umontreal.ca> writes:

> I can see its use while debugging but I can't imagine it being of any
> use in real ELisp code because it's much too blunt.
> [ Personally I'd put a `--` in its name and/or add some blurb in the
> docstring explaining it's only for debugging.  ]

Would it make sense to have something like 'debug-elisp.el' where we
could put all/most functions that are only useful when debugging?
Then we would decrease the risk of users stumbling upon our sharper
tools unless they actively go looking for them.  In this case, I can
imagine running this command by mistake or mistakenly messing up quite
a few things in a typical user session.

Orthogonally, could we place all/most such functions under some prefix
like "debug-"?

I'm not sure this makes sense, as I can't think of any more commands
that fall in that category, but the 'bidi-display-reordering' variable
is one candidate for a prefix, I think.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]