[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: No, not solved (was: undo-auto--undoable-change infloop)

From: Eli Zaretskii
Subject: Re: No, not solved (was: undo-auto--undoable-change infloop)
Date: Fri, 29 Jul 2022 09:05:03 +0300

> From: Michael Heerdegen <michael_heerdegen@web.de>
> Cc: emacs-devel@gnu.org
> Date: Fri, 29 Jul 2022 02:40:11 +0200
> Eli Zaretskii <eliz@gnu.org> writes:
> > Any reason why you didn't use temporary buffers for that?  AFAIR, undo
> > is disabled there automatically.
> I actually do, I use buffers from evaluating
> (list (generate-new-buffer " *El-Search Work Buffer A*" t)
>       (generate-new-buffer " *El-Search Work Buffer B*" t))
> But the problem is back.  After I had checked that `buffer-undo-list'
> had been t all the time and my change could not have had an effect at
> all, the problem instantly reappeared out of nothing.  I did not change
> anything!  This is really mysterious and very frustrating.  I have
> wasted hours now for this stuff and do not know a bit more than when it
> started.

So what is the problem, again?  Can you describe what your Lisp
program does, and what are the symptoms of the problem when it

If the problem is with timers, what does list-timers report when the
problem happens?

If you have a reproducible recipe, perhaps submit a bug report.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]