[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Display of undisplayable characters: \U01F3A8 instead of diamond

From: Alan Mackenzie
Subject: Re: Display of undisplayable characters: \U01F3A8 instead of diamond
Date: Sun, 28 Aug 2022 16:14:01 +0000

Hello, Gregory.

On Sun, Aug 28, 2022 at 15:46:23 +0000, Gregory Heytings wrote:

> > In my copy of fbterm C-M-e aborts the fbterm session without saving 
> > anything.  C-M-c and C-M-d are similarly stolen, making this version of 
> > fbterm unusable for Emacs.

> That means either that you're running fbterm and Emacs as root, or that 
> fbterm is installed with a setuid bit or has the SYS_TTY_CONFIG 
> capability, which you can remove (see upthread).

All these reservations surely need to go into your entry in the PROBLEMS
file.  People run Emacs as root, e.g. for editing configuration files.
Do we really expect users to be able to flip setuid bits, or remove
SYS_TTY_CONFIG capability?  Myself, I don't even know what the second of
these means, though I will examine the thread to try and find out.

> > Have you tried these key combinations?  Do they really get through to 
> > Emacs on your system?

> Yes I tried, and yes they did.  I've been using fbterm for quite some time 
> in fact (but unlike you I don't use the console most of the time).

OK.  There remains the mystery of why M-: (tty-type) returns "linux" on
your system, but "fbterm" on mine.

Alan Mackenzie (Nuremberg, Germany).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]