emacs-diffs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

master 9ebf519: Turn Eldoc, Xref and Project into GNU ELPA :core package


From: Joo Tvora
Subject: master 9ebf519: Turn Eldoc, Xref and Project into GNU ELPA :core packages
Date: Wed, 13 May 2020 06:38:35 -0400 (EDT)

branch: master
commit 9ebf51999ce58cccc2a228fd07a18c7b472dd3fd
Author: João Távora <address@hidden>
Commit: João Távora <address@hidden>

    Turn Eldoc, Xref and Project into GNU ELPA :core packages
    
    The new packages state they require Emacs 26.3 to function, but a
    small part of project.el breaks this "soft" rule: the two functions
    requiring fileloop.el are incompatible with Emacs 26.3.
    
    * lisp/jsonrpc.el: Tweak comment near Package-Requires.
    
    * lisp/emacs-lisp/eldoc.el: Add Version and Package-Requires.
    
    * lisp/progmodes/flymake.el: Add comment near Package-Requires.
    
    * lisp/progmodes/project.el: Add Version and Package-Requires.
    
    * lisp/progmodes/xref.el: Add Version and Package-Requires.
---
 lisp/emacs-lisp/eldoc.el  | 5 +++++
 lisp/jsonrpc.el           | 6 +++---
 lisp/progmodes/flymake.el | 5 ++++-
 lisp/progmodes/project.el | 5 +++++
 lisp/progmodes/xref.el    | 5 +++++
 5 files changed, 22 insertions(+), 4 deletions(-)

diff --git a/lisp/emacs-lisp/eldoc.el b/lisp/emacs-lisp/eldoc.el
index 4a2e748..ef5dbf8 100644
--- a/lisp/emacs-lisp/eldoc.el
+++ b/lisp/emacs-lisp/eldoc.el
@@ -5,6 +5,11 @@
 ;; Author: Noah Friedman <address@hidden>
 ;; Keywords: extensions
 ;; Created: 1995-10-06
+;; Version: 1.0.0
+;; Package-Requires: ((emacs "26.3"))
+
+;; This is a GNU ELPA :core package.  Avoid functionality that is not
+;; compatible with the version of Emacs recorded above.
 
 ;; This file is part of GNU Emacs.
 
diff --git a/lisp/jsonrpc.el b/lisp/jsonrpc.el
index 6cf4131..293dfaa 100644
--- a/lisp/jsonrpc.el
+++ b/lisp/jsonrpc.el
@@ -4,11 +4,11 @@
 
 ;; Author: João Távora <address@hidden>
 ;; Keywords: processes, languages, extensions
-;; Package-Requires: ((emacs "25.2"))
 ;; Version: 1.0.11
+;; Package-Requires: ((emacs "25.2"))
 
-;; This is an Elpa :core package.  Don't use functionality that is not
-;; compatible with Emacs 25.2.
+;; This is a GNU ELPA :core package.  Avoid functionality that is not
+;; compatible with the version of Emacs recorded above.
 
 ;; This program is free software; you can redistribute it and/or modify
 ;; it under the terms of the GNU General Public License as published by
diff --git a/lisp/progmodes/flymake.el b/lisp/progmodes/flymake.el
index 7fca9da..93a09d1 100644
--- a/lisp/progmodes/flymake.el
+++ b/lisp/progmodes/flymake.el
@@ -5,8 +5,11 @@
 ;; Author: Pavel Kobyakov <address@hidden>
 ;; Maintainer: João Távora <address@hidden>
 ;; Version: 1.0.8
-;; Package-Requires: ((emacs "26.1"))
 ;; Keywords: c languages tools
+;; Package-Requires: ((emacs "26.1"))
+
+;; This is a GNU ELPA :core package.  Avoid functionality that is not
+;; compatible with the version of Emacs recorded above.
 
 ;; This file is part of GNU Emacs.
 
diff --git a/lisp/progmodes/project.el b/lisp/progmodes/project.el
index f5f4092..ca8b5fa 100644
--- a/lisp/progmodes/project.el
+++ b/lisp/progmodes/project.el
@@ -1,6 +1,11 @@
 ;;; project.el --- Operations on the current project  -*- lexical-binding: t; 
-*-
 
 ;; Copyright (C) 2015-2020 Free Software Foundation, Inc.
+;; Version: 0.1
+;; Package-Requires: ((emacs "26.3"))
+
+;; This is a GNU ELPA :core package.  Avoid using functionality that
+;; not compatible with the version of Emacs recorded above.
 
 ;; This file is part of GNU Emacs.
 
diff --git a/lisp/progmodes/xref.el b/lisp/progmodes/xref.el
index c36a9bd..b516ff0 100644
--- a/lisp/progmodes/xref.el
+++ b/lisp/progmodes/xref.el
@@ -1,6 +1,11 @@
 ;; xref.el --- Cross-referencing commands              -*-lexical-binding:t-*-
 
 ;; Copyright (C) 2014-2020 Free Software Foundation, Inc.
+;; Version: 1.0.0
+;; Package-Requires: ((emacs "26.3") (project "0.1"))
+
+;; This is a GNU ELPA :core package.  Avoid functionality that is not
+;; compatible with the version of Emacs recorded above.
 
 ;; This file is part of GNU Emacs.
 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]