[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] todo items not working?

From: Saketh
Subject: Re: [Orgmode] todo items not working?
Date: Thu, 30 Apr 2009 13:54:33 -0400

Greg, Matthew, Giovanni, Nick, and Memnon:

I did the 'edebug-defun' as Nick suggested and found the problem. An obscure library that was installed on both of my machines modified outline-regexp before org was loaded (as Nick had guessed), causing the wacky behavior.

Thank you very much for your help!


On Thu, Apr 30, 2009 at 12:45 AM, Saketh <address@hidden> wrote:
As expected, it says "C-c C-t runs the command org-todo." The command "M-x org-todo" also does the same thing. Again, the same thing is:

* Tasks
** TODO This is a test


* Tasks
* TODO * TODO This is a test

I'm still not able to figure it out, especially since this is out-of-the-box behavior. More interestingly, I've tried it on another machine (which has Carbon Emacs, org-mode v4.67c), and the same behavior occurs.

However, when the TODO items are at the top level (one asterisk), org-todo works fine.

On Thu, Apr 30, 2009 at 12:31 AM, Nick Dokos <address@hidden> wrote:
Saketh <address@hidden> wrote:

> Greg: Okay, I have just done so, but I get the same behavior.
> Matthew: My "customization" is simply the series of commands listed in the
> documentation. That is:
> (add-to-list 'load-path "~/elisp/org-6.26d/lisp")
> (add-to-list 'auto-mode-alist '("\\.org$" . org-mode))
> (require 'org-install)
> Giovanni: Shift + Left Arrow (or Right Arrow) produces the exact same
> behavior, for some reason.
> Since I am doing this "from scratch" on Ubuntu Linux, I am surprised that I
> am getting such weird behavior with "C-c C-t" and "Shift + Arrows".

What does

    C-h c C-c C-t

say? Or does it cut it short and give you something after the C-c?
Either way, the answer should be interesting.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]