[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] overzealous file link creation

From: Nick Dokos
Subject: Re: [Orgmode] overzealous file link creation
Date: Tue, 11 Aug 2009 17:36:28 -0400

Dan Davison <address@hidden> wrote:

> Recently I've been randomly losing the string 'file' from all sorts of
> documents. Up until now I had no explanation. It's not the sort of
> question one wants to ask on public mailing lists.
> OK, so if you call org-cycle "in the vicinity" of a word that starts
> with the string 'file', then it eats up 'file' and prompts for link
> insertion. This is true in buffers that are not in org-mode or
> orgstruct*-mode. (I call org-cycle the whole time in order to use
> outline-minor-mode, but o-m-m doesn't have to be turned on to cause
> this.)
> Try putting the following fragment into python-mode, and getting rid of
> the asterisks. Then org-cycle issued with point at any of the asterisked
> locations eats the string 'file' and prompts for a link.
> def f(filepath):
>     print(
>         *filepath*)*
> *
> *def g(arg):
>     return arg
> This is with latest git.

I cannot reproduce this. I created foo.py with the above contents, deleted
the asterisks, saved the file and then tried M-x org-cycle at the various
places indicated by the asterisks. In no case does a "file" disappear.

At the three places around filepath in function f(), nothing happens.

At the beginning of the def g(...), it folds the function (I also tried
at the beginning of the definition of f, with the same result). In all of
these cases, the buffer does not get modified.

The only case where the buffer is modified is at the beginning of the empty
line between the functions: I get a tab added (actually a bunch of spaces -
not sure whether it makes a difference but I set indent-tabs-mode to nil).

I think we need more people to try out the experiment!-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]