[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] export (as latex) a large number of org files in a directo

From: Stephen Tucker
Subject: Re: [Orgmode] export (as latex) a large number of org files in a directory
Date: Sun, 30 Aug 2009 12:11:54 -0700 (PDT)

Hi Nick, thanks for the response! Actually in the code that I had pasted, the 
emacs --batch call is all on one line (so no need to escape newlines there). I 
tried your code with both
but got 
Cannot open load file: org-macs
in both cases I also added a line, 
--eval "(load \"/Applications/Emacs.app/Contents/Resources/lisp/org/org.elc\")" 
to replace the --load option but same deal.

I do in fact have org-macs in my 'orglib' directories so I tried loading them 
explicitly (with multiple --load specifications), but it still doesn't work 
(Still "Cannot open load file" pointing to some org file or subst-ksc, 
depending on how many or in what order org .el files are loaded). Any more 



----- Original Message ----
From: Nick Dokos <address@hidden>
To: Stephen Tucker <address@hidden>
Cc: address@hidden; address@hidden
Sent: Sunday, August 30, 2009 8:04:06 AM
Subject: Re: [Orgmode] export (as latex) a large number of org files in a 

Stephen Tucker <address@hidden> wrote:

> Hi, I am trying to export a bunch of .org files stored in a directory as 
> latex files. I have tried two methods:
> (1) 
> -------------------------------------------------------------------------------------------
> At the bash prompt (I am using OS X):
> bash$ emacs --batch
> --load=/Applications/Emacs.app/Contents/Resources/lisp/org/org.elc
> --visit=file.org --funcall org-export-as-latex-batch'
> and I get an error:
> "Cannot open load file: subst-ksc"
> If I can get this to work, then I can embed this system call in a shell 
> script and call it iteratively on a list of .org files retrieved from, say, 
> Python or Bash (changing 'file.org' appropriately each time).

Did you escape the newlines? If you cut-n-pasted from the
org-export-as-latex-batch help, you fell into the trap :-) Maybe the
documentation of the function could be changed to add the backslashes?

The following script (I call it org-to-latex) works fine on linux:

--8<---------------cut here---------------start------------->8---
#! /bin/bash

emacs   --batch \
        --load=$orglib/org.elc \
        --eval "(setq org-export-headline-levels 2)" \
        --visit=$1 --funcall org-export-as-latex-batch
--8<---------------cut here---------------end--------------->8---

You can add a loop in it too - or do the loop by hand:

--8<---------------cut here---------------start------------->8---
for x in *.org
        org-to-latex $x
--8<---------------cut here---------------end--------------->8---



reply via email to

[Prev in Thread] Current Thread [Next in Thread]