emacs-orgmode
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Plotting date on xaxis


From: Eric S Fraga
Subject: Re: [Orgmode] Plotting date on xaxis
Date: Tue, 23 Feb 2010 22:52:39 +0000
User-agent: Wanderlust/2.15.6 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.7 Emacs/23.1 (i486-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)

On Tue, 23 Feb 2010 07:47:25 -0700, "Eric Schulte" <address@hidden> wrote:
> 
> Hi Johan,
> 
> You could try plotting your table using standard org-mode date formats
> which org-plot will understand without any need to specify a timefmt
> string.

Eric,

thanks for this suggestion as well as the one using org-babel (which I
would have typically used myself these days).  However, the point
still stands: why doesn't what Johan tried initially work?

I have narrowed down what causes the problem although I don't
understand why (I haven't had any time to look at the elisp code).
Basically, the problem with Johan's initial table was the extra empty
row at the end:

--8<---------------cut here---------------start------------->8---
#+PLOT: title:"Weight" ind:1 deps:(2) type:2d with:linespoints set:"xdata time" 
set:"timefmt '%Y-%m-%d'" set:"yrange [90:]"
|       Date |   Kg |
|------------+------|
| 2010-02-21 | 95.0 |
| 2010-02-22 | 93.0 |
| 2010-02-23 | 92.0 |
| 2010-02-24 | 91.5 |
| 2010-02-25 | 91.0 |
| 2010-02-28 | 92.0 |
|            |      |
--8<---------------cut here---------------end--------------->8---

With the empty row there, the "using 1:2" option to the gnuplot plot
command is not generated correctly, instead generating "using
1:xticlable(1)" which gnuplot doesn't like!  If the last row is
deleted, everything works just fine (even if February doesn't have 29
days in 2010 ;-).

HTH,
eric




reply via email to

[Prev in Thread] Current Thread [Next in Thread]