emacs-orgmode
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Plotting date on xaxis


From: Eric S Fraga
Subject: Re: [Orgmode] Plotting date on xaxis
Date: Thu, 25 Feb 2010 20:11:18 +0000
User-agent: Wanderlust/2.15.6 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.7 Emacs/23.1 (i486-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)

On Thu, 25 Feb 2010 10:44:33 -0700, "Eric Schulte" <address@hidden> wrote:
> 
> Eric S Fraga <address@hidden> writes:
> 

[...]

> > Well, good intentions is one thing, wrong behaviour is another?  If
> > the user has specified "ind:1 deps:(2)", even if org-plot identifies
> > column 1 as having labels for the tic marks, the generated parameter
> > to the plot command should be, at best:
> >
> >   ... using 1:2:xticlabels(1) ...
> >
> 
> I just applied a patch which results in the above plotting command, and
> yields the following gnuplot error when the table contains an empty line
> 
>  "illegal day of month"
> 
> which to me seems entirely appropriate.

It does indeed seem perfectly appropriate!  Thanks.

> All of the plots form the org-plot page on worg still work with this
> patch (which amounts to org-plot's test suite), so I relatively
> confident that it shouldn't break any existing functionality.
> 
> One problem with org-plot's attempt to guess the best action in each
> situation is that the code will get increasingly ugly as these corner
> cases continue to arise, and as that happens it becomes increasingly
> difficult to know a-priori if a patch will cause unforeseen problems.

Yes, I can imagine.  I guess, for Johan's benefit, that it's best to
move on to org-babel for the more complex problems leaving the direct
gnuplot support for "simple" cases!

Thanks again,
eric




reply via email to

[Prev in Thread] Current Thread [Next in Thread]