[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] beamer export

From: Carsten Dominik
Subject: Re: [Orgmode] beamer export
Date: Thu, 19 Aug 2010 23:06:42 +0200

On Aug 19, 2010, at 5:16 PM, Antony Ware wrote:

I've been having a problem exporting to beamer. I've now found the problem and fixed it, but it was (to my mind) something pretty obscure, and I think it might be of interest to the list, at least as a salutary tale.

When I opened an org file such as the example beamer presentation from the manual (section 12.6.6) and executed C-c C-e d, it kept generating a .tex file with an article document class, instead of the expected beamer class.

After a few days of frustrated searching through the manual and tutorials, and this list, for any clues, I found some advice to run something like

/usr/bin/emacs -Q -l test.el

with a series of versions of test.el progressively approximating my .emacs file. I was expecting the problem to lie in one of my org- or latex-specific settings, but eventually found the cause of the problem to be that the variable


was being set to nil (its default value) as one of my custom-set- variables. I don't remember why. Anyway, according to the information from C-h v, this makes the setting buffer-local, and for some reason that fouled up the beamer export. When I commented out that line, everything worked as advertised.

I'd be interested to hear from anyone who could shed light on why that might be.


apparently Org does do a search that relies on case-fold-search
being t.  Normally when this is the case
I try to set this explicitly to t during the function call.
Can you make a minimal example with your setup and a small file which reproduced the error?

- Carsten

reply via email to

[Prev in Thread] Current Thread [Next in Thread]