[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] Re: org-odt list bug - help reproducing?

From: Jambunathan K
Subject: [Orgmode] Re: org-odt list bug - help reproducing?
Date: Sat, 13 Nov 2010 02:21:52 +0530
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.91 (windows-nt)


> On Wed, Nov 10, 2010 at 11:14 AM, Jambunathan K <address@hidden> wrote:
>     Matt
>     I am unable to reproduce the said behaviour.
>     From my work-area (which is same as that in git), the odt produced is
>     valid. I am attaching the odts produced in my work area. Let me know if
>     what is attached is not what you expect.
> I wonder if anyone on the list can reproduce the bug I'm finding in
> Jambunathan's odt exporter?   The attached org file creates the attached
> invalid odt file for me -- this is true both on my main laptop and in a clean
> environment I just went to some trouble to create on another computer, but J
> cannot reproduce the error.  I'm wondering if perhaps there's some implicit
> dependency in J's code somewhere that neither of us sees, and that isn't
> fulfilled on either of my systems.  I can't think of any other explanation....

Looks like it had been a pretty rough start for you ... Tried one more
round in reproducing the problem. But I cannot reproduce it at all.

If someone helps me in reproducing the bug, I will be happy to address
it in no time.

To encourage new users to try out the OpenOffice exporter, I have
revised the instructions in "How to export to OpenOffice?" section of
the README.org file.

- http://repo.or.cz/w/org-mode/oo.git/blob/HEAD:/contrib/odt/README.org

I suggest that you download the entire repo or the snapshot. Check that
you are using the URL that ends in "oo.git".

I am *pretty confident* that the OpenOffice exporter can handle simple
text - headlines, paragraphs, lists - very reliably.

How I tried reproducing the problem and failed:

1. I freshly cloned the repository.
2. Started emacs without any customization.
   "C:\Program Files\emacs-23.1.91\bin\runemacs.exe" --debug-init -Q
3. M-: (setq org-odt-base-dir "~/src/oo/") RET
4. M-x (load-file (expand-file-name "./contrib/odt/setup.el" org-odt-base-dir))
5. C-x C-f desc_test_short_2.org
6. I did a C-c C-e O.
7. I am seeing that OpenOffice launches and opens the file
   desc_test_short_2.odt without any complaints.

Jambunathan K.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]