[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] Re: s-tab not working as intended in kde's konsole

From: Izzie
Subject: [O] Re: s-tab not working as intended in kde's konsole
Date: Thu, 24 Mar 2011 00:38:19 +0000 (UTC)
User-agent: Loom/3.14 (http://gmane.org/)

Achim Gratz <Stromeko <at> nexgo.de> writes:

> Izzie <ml_orgmode.kapush <at> antichef.net> writes:
> > Hi, I'm a newcomer to orgmode and a basic emacs user who has trouble with 
> > shortcuts not doing what they should. I don't know how to fix it.
> >
> > This problem occurs on an aptosid (debian sid 64-bits) laptop with kde when 
> > running emacs in konsole with the -nw parameter. 
> >
> > Instead of folding/unfolding S-TAB seems to take focus away as the cursor 
> > from full to empty but nothing. 
> This doesn't appear to have anything to do with orgmode, but... KDE
> defines a lot of global shortcuts in addition to each application being
> able to define their own shortcuts on top of that.  If you want to check
> if that's the problem, the window menu (right click on title bar or
> frame) should offer "Extended->Special settings" or whatever
> localization calls these.  Temporarily disable all global shortcuts and
> see if it works better (don't forget that none of the shortcuts will
> work while the window has focus).  If you can input S-Tab now, you can
> then decide if it's better to remove the shortcut or to redefine the key
> sequence in Emacs.  If it still doesn't work, maybe your keyboard isn't
> set up correctly or the character encoding inside the shell is
> inconsistent with the settings in the terminal emulation.
> Achim.

Wow! You just opened me to a whole new world of possibilities in advanced 
window management I didn't suspect existed. No luck though as disabling kde 
shortcuts didn't change a thing. With both konsole shortcuts and kde shortcuts 
out of the way the problem is still here.

I don't really what to do to check is the keyboard,a fr_CH qwertz btw, is 
correctly set up. I looked up konsole settings and found a section about 
keybindings set on default (xfree4), I tried the other option "linux console" 
but it didn't fix my problem, and I found encoding is set to utf-8.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]