[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] export problems

From: Eric Abrahamsen
Subject: Re: [O] export problems
Date: Fri, 03 Jun 2011 21:07:13 -0700
User-agent: Gnus/5.110018 (No Gnus v0.18) Emacs/23.2 (gnu/linux)

Eric Abrahamsen <address@hidden> writes:

> Nick Dokos <address@hidden> writes:
>> Nick Dokos <address@hidden> wrote:
>>> Eric Abrahamsen <address@hidden> wrote:
>>> > It was while trying to produce a backtrace (with edebug) that I
>>> > discovered that re-evaluating the code fixed the problem. I set
>>> > debug-on-error to t and reproduced the error, which gave me this:
>>> > 
>>> > Debugger entered--Lisp error: (error "Cannot return from the debugger in 
>>> > an error")
>>> >   internal-temp-output-buffer-show(#<buffer *Org Export/Publishing Help*>)
>>> >   org-export(nil)
>>> >   call-interactively(org-export nil nil)
>>> > 
>>> > Presumably this isn't really what's needed -- can you provide a pointer
>>> > to producing a more useful backtrace?
>>> > 
>>> Only the usual suspects: you are loading uncompiled code I hope? I don't
>>> even have the function in either of my emacsen (24.0.50 and 23.1.1):
>>> does C-h f internal-temp-output-buffer-show RET show anything in yours?
>> I see some messages about internal-temp-output-buffer-show when
>> googling: they seem related to Stefan Monnier's effort to make
>> with-output-to-temp-buffer a Lisp macro (rather than a special form in C
>> code, IIUC) - but this seems to be bleeding edge stuff, not 23.2. Are
>> you perhaps picking up emacs bits and pieces from places you shouldn't?
>> Maybe Stefan (cc:ed) has some ideas.
>> Nick
> Aha, I did once try building emacs 24 on this machine, for the heck of
> it, and it's still hanging around under /usr/local/bin. I'm not sure how
> much work would be required to uproot it entirely, but I can give it a
> shot, particularly with the lisp libraries, and see if that makes a
> difference.
> Thanks for the hint,
> Eric

Nope, pretty sure I got it all out of there, and I'm still getting the
same error, and =with-output-to-temp-buffer= is definitely still a
c-source code function.

I re-installed emacs from the Ubuntu repositories for good measure, to
no avail. If I run emacs -Q so that the org code base that's loaded is
the default, the error disappears. Adding git org to the load path,
reloading org and trying again is enough to make the error return.

Running emacs -Q from the command line produces:

Warning: Lisp directory `/usr/local/share/emacs/23.2/site-lisp' does not exist.
Warning: Lisp directory `/usr/local/share/emacs/site-lisp' does not exist.

Which I've never seen before, and which seems like a warning sign. I'm
quite prepared to believe that I've somehow got tangled codebases, but I
really don't know where to look next…


reply via email to

[Prev in Thread] Current Thread [Next in Thread]