[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] problems with org-edit-special and python

From: Dirk Scharff
Subject: [O] problems with org-edit-special and python
Date: Mon, 18 Jul 2011 23:13:21 +0200

Hi all!

I'm fairly new to emacs (and org-mode :)), so I'm sorry in advance for 
eventually missing something completely obvious. While I kind of expect my 
problem to be something with my emacs setup it does only happen with org-mode 
so I'm posting it here.

My test file (for learning purposes) contains the following (empty) code-block: 
#+source : the_beginning
#+begin_src python

When I try to run org-edit-special (C-c ') in the python source block an empty 
buffer is opened as expected. My mini-buffer states the following:
"Language mode 'python-mode' fails with: "Invalid file-name". 
Trying to call python-mode manually in the new buffer doesn't work. (It works 
fine in other buffers). I can't leave the new buffer by using C-c' again. 

I tried the same with a latex code block and it worked without problems. 

I'm quite satisfied with my emacs python setup, which seems to run perfectly 
fine on its own. 

I have to admit I don't even know where to start for resolving this. Can 
someone point me in the right direction? 

best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]