[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] Org-edit-special and C-x C-s strange behavior

From: Leo Alekseyev
Subject: Re: [O] Org-edit-special and C-x C-s strange behavior
Date: Thu, 12 Jan 2012 07:55:00 -0600

On Thu, Jan 12, 2012 at 4:14 AM, Andreas Leha
<address@hidden> wrote:
> Eric S Fraga <address@hidden> writes:
>> Leo Alekseyev <address@hidden> writes:
>>>> Eric S Fraga <address@hidden> writes:
>>>>> What version of org are you using?  I ask because I used to experience
>>>>> the annoyance you describe a while back; more recently (since at least a
>>>>> few months ago), hitting C-x C-s no longer has any negative impact: it
>>>>> saves the file, or at least appears to.
>>>>> You still have to C-c ' to get back to the full buffer, mind you, but
>>>>> that's better, IMO, than changing the behaviour of such a fundamental
>>>>> key binding as C-x C-s.
>>> It appears that this bug is Emacs-version dependent: it functions as
>>> you describe with 23.2, but the buffer gets buried (with an error
>>> message "basic-save-buffer: Wrong type argument: stringp, nil") in
>>> 24.0.92.  Org mode is the current git HEAD.  I tried to step through
>>> basic-save-buffer in edebug, but I couldn't catch the error (I'm not
>>> very experienced with edebug).  Can someone test this on Emacs 24 and
>>> confirm what I'm seeing?
>> I am using 24.0.92 and I have no problems at all (just tried right
>> now).
>> One difference, however, could be the window configurations we
>> use.  Specifically, I have
>>       (setq org-src-window-setup (quote current-window))

Yes, this works. It's also a more sensible default. However, it
doesn't change the fact that there's a bug, it just switches to a case
where the bug isn't triggered :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]