[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] invalid byte-code error when publishing

From: Sebastien Vauban
Subject: Re: [O] invalid byte-code error when publishing
Date: Tue, 20 Aug 2013 15:48:03 +0200
User-agent: Gnus/5.130006 (Ma Gnus v0.6) Emacs/24.3 (windows-nt)

Mehul Sanghvi wrote:
> Sebastien Vauban wrote:
>> Mehul Sanghvi wrote:
>>>> Mehul Sanghvi wrote:
>>>>> The error only occurs if I'm using org-babl. The offending piece of code
>>>>> I've got is:
>>>>> #+BEGIN_SRC emacs-lisp
>>>>> (setq tramp-default-method "ssh")
>>>>> #+END_SRC
>>>>> If I remove the #+BEGIN_SRC and #+END_SRC than everything works fine and
>>>>> I'm able to publish.
>>>> Would this fix it?
>>>>   #+BEGIN_SRC emacs-lisp :eval no
>>>>   (setq tramp-default-method "ssh")
>>>>   #+END_SRC
>>> Thanks for the suggestion. That does not fix the problem. I still get the
>>> same error as before.
>> Check out the value of:
>> - `org-babel-default-header-args', and
>> - `org-babel-default-header-args:emacs-lisp'.
>> And try whether `:eval query' makes a difference (when answering yes, and
>> when answering no)?
> Using ':eval query' does not make a difference. It does not prompt for yes
> or no.

Then, there are now 2 things I don't understand:

- why it does not query you for eval?
- why that code gets you in troubles?

I'm out of ideas here...

Try with an ECM, or with emacs -Q?

Best regards,

Sebastien Vauban

reply via email to

[Prev in Thread] Current Thread [Next in Thread]