[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] Possible bug? Links using 'file+Emacs:' don't work. (Was: Re: Unable

From: Alexis
Subject: [O] Possible bug? Links using 'file+Emacs:' don't work. (Was: Re: Unable to get file link search to work)
Date: Sun, 23 Feb 2014 19:31:46 +1100
User-agent: mu4e; emacs 24.3.4

Christian Moe <address@hidden> writes:

> Just to say, I reproduce it, so I think it's a bug. Note, the below
> only happens for me when using "file+emacs:" to force opening in
> emacs. The links work with regular "file:" links, or just starting the
> link with "./" Since my .org files open with emacs anyway, I normally
> wouldn't add "+emacs". But the manual suggests I could.

Hi Christian,

Thanks for taking the time to look into this!

i was using 'file+emacs:' because when i just used 'file:', the .org
file would be opened using 'less', not Emacs. As a result of your email,
i checked out the documentation for org-open-at-point; it said that
providing a prefix argument would force opening in Emacs. So i removed
the '+emacs' from my example link, and then tried opening it via
C-u C-c C-o - and it worked!

i checked the value of org-file-apps, to see why org-open-at-point was
using 'less', rather than Emacs, to open .org files. It turns out there
was a typo in how i was setting the value of org-file-apps, causing it
to have a nonsense value - and i guess this caused org-mode to fall back
to using 'less' as a default. Setting the value of org-file-apps to a
correct value - including ("org" . emacs) as part of it - resulted in
'file:' links being opened in Emacs, rather than with 'less'.

However, 'file+emacs:' links still exhibit the incorrect behaviour i
described in my original email, and which you experienced also. So it
looks like there is indeed a bug here - or, the 'file+emacs:' example
should be removed from section 4.3 of the Org manual.

Thanks again!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]