[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] (setq org-icalendar-store-UID t) not working with --batch

From: Boyd Kelly
Subject: [O] (setq org-icalendar-store-UID t) not working with --batch
Date: Fri, 28 Feb 2014 12:45:22 -0800


Total newbie here....  I want to export my agenda stuff to ical and potentially sync with google.  I have this in my .emacs:

;; found on the net to include todo itmes with iCalendar export
(setq org-icalendar-include-todo t)
(setq org-icalendar-store-UID t)

(setq org-icalendar-use-scheduled '(todo-start event-if-todo event-if-not-todo))
(setq org-icalendar-use-deadline '(todo-due event-if-todo event-if-not-todo))
(setq org-combined-agenda-icalendar-file "~/combined.ics")

When I run C-c C-a I to export all my agenda files, all works fine.  I get my todo's also as events, and the UID is added as a property to the .org file.

But when I run:  emacs -l ~/.emacs -eval '(org-export-icalendar-all-agenda-files)' --batch

It doesn't store the UID.

I tried my very first attempt at something lisp, and did this:

(defun org-mycal-export ()
                (setq org-icalendar-include-todo t)
                (setq org-icalendar-store-UID t)

​With the same result.  If I run M-x org-mycal-export, I get the UID entered to my agenda file.  But if I run emacs --batch -l ~/.emacs ​-eval '(org-mycal-export)', it doesn't insert the UID.

Any suggestions?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]