[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] use of 'system in ox-odt.el

From: Matt Price
Subject: Re: [O] use of 'system in ox-odt.el
Date: Tue, 19 May 2015 14:19:10 -0400

Resenting to list (sorry rasmus)

---------- Forwarded message ----------
From: "Matt Price" <address@hidden>
Date: May 19, 2015 11:04
Subject: Re: [O] use of 'system in ox-odt.el
To: "Rasmus" <address@hidden>

On Tue, May 19, 2015 at 10:57 AM, Rasmus <address@hidden> wrote:
Matt Price <address@hidden> writes:

> When I export-and-open to odt, org doesn't open the resultant odt, even
> though I get a message:
> Running xdg-open /home/matt/RLG231/RLG231Syllabus.odt...done
> org-open-file works fine on links in an org buffer, and an anser on the
> following stackoverflow page suggests the issue is in ox-odt.el:

With your change it open the odt file as a tar-mode file from Emacs -q.
Without your change it doesn't open it at all.  BTW: My Emacs also doesn't
open html exports in Fx files when I use C-c C-e h-o.  I never tried to
debug it though...

Yeah, I just got that too -- I realized I hadn't been testing it in the right environment, shoot.  this modification worked for me (also form the same forum):

 (setcdr (assq 'system org-file-apps-defaults-gnu ) '(call-process "xdg-open" nil 0 nil file))

Not sure why this should work when the default fails.  Fx opens html exports for me with C-c C-e h-o -- also not sure why that should work and odt fail. 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]