[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] Bugreport: htmlized.el 1.43 and Org-mode Agenda export to html with

From: Judith Bush
Subject: [O] Bugreport: htmlized.el 1.43 and Org-mode Agenda export to html with C-x C-w has broken http links
Date: Mon, 25 May 2015 14:40:36 +0000 (UTC)
User-agent: Loom/3.14 (http://gmane.org/)

I've recently installed emacs 24.5 on two different OS X Mavericks
machines, once with Mac Ports, once from the tarball. I didn't see
html as an option when using C-c C-e in org-mode, so i ran find across
the machine installed with tarball and couldn't find htmlize.el. I
fetched version 1.43 and put it in my load path: html now appears in
C-c C-e. (This loadpath is mirrored between the two machines.)

Now when i run C-x C-w at the agenda view, i have a satisfactory html
export with the exception of links. The URL includes the close
bracket, open bracket and first word of the link text. (Angle brackets
replaced with curly braces in hopes to preserve content across
rendering systems.)

{a href="https://oclc.webex.com/oclc/j.php?blahblahblah][Webex"}Webex{/a}

Note that the engine is able to figure out the end of the URL because
the second word in the link text in the org document becomes its own
second link, well formed:

{a href="https://docs.google.com/document/d/blahblah/edit][Engineering"}\
href="https://docs.google.com/document/d/blahblah/edit"} Doc{/a}

This annoying behavior occurs on both machines.

Experiments on the macports machine result in the following. An export
of an org file to html via C-c C-e produces well formed links; an
export of the agenda via M-x org-export-dispatch produces well formed
links, but all the content is in one paragraph tag and all the lines
run together.

The orgfile source reads: '** 10:00 Team checkin -
 [[https://oclc.webex.com/oclc/j.php?MTID%blah][Webex]] -

Confirmed in post at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]