emacs-orgmode
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] babel stopping export after updating to org 8.3


From: Robert Klein
Subject: Re: [O] babel stopping export after updating to org 8.3
Date: Tue, 15 Sep 2015 11:21:11 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.2.0

Hi

Aviv wrote:
> Robert Klein <roklein <at> roklein.de> writes:
> 
>>
>> Hi
>>
>> Aviv wrote:
>>
>>> Hi! 
>>>
>>> I just upgraded to org 8.3 and am stuck with an export issue.
>>>
>>> When I try to export a file with just "#+begin_src" and " "#+end_src" as 
>>> the 
>>> only lines, I get the error 
>>> "user-error: No language for src block: (unnamed)". 
>>>
>>> It seems like it is calling org-babel-exp-process-buffer -- but there is no 
>>> reason that I can tell that is being called.  (org-export-babel-evaluate is 
>>> definitely nil, thought other testing seems to indicate that shouldn't even 
>>> matter)
>>>
>>> I've tried this in a clean "emacs -q" emacs and there is no issue -- but I 
>>> still have the issue with an empty init.el! 
>>>
>>> Any idea what could be wrong?  Thanks!
>>>
>>>
>>
>> You need to specify a language, e.g.
>>
>> #+begin_src foo
>> #+end_src
>>
>> You can use any string for language.  However, if you export to latex
>> you want to either
>>
> 
> Sorry, I should have clarified. I know that the error is a result of not 
> specifying a language. But it wasn't necessary to specify one before, and it 
> seems like it's better for it not to actually be required now either, unless 
> I'm missing something -- should I also specify "pseudocode"? 
> 
> Also, if that was correct behavior, it should be described as a breaking 
> change from 8.2 to 8.3, and it's not at http://orgmode.org/Changes.html .

For me org version 7.9.3f (came with emacs 24.3) a source block without
language also fails with ┬░Source block missing language specification"
as soon as the source block isn't empty -- on 8.3.1 it also fails on
empty source blocks, too.

Afaik only begin_example and end_example don't need a language
specification.

Note: I get fooled by the language specification regularly; either I
forget to specify the language on the begin_src line (where I think it
is Ok to get an error -- I might want to have syntax highlighting or
even get the code executed)  or I put the language on the end_src line,
too, which imho should be ignored by the exporter :)



> 
> --
> 
> So, I just checked the manual and it seems like "#+begin_src" does (now?) 
> require a language block, but given that up until now this sort of export did 
> not cause errors, it seems odd to require that all the sudden and break all 
> exports that depend on it without alerting users. 
> 
> That said, I figured out the distinction between "emacs -q" and just using an
> empty init.el file. It turns out that "-q" actually loads org version 8.2.10!
> (while an empty init.el load 8.3.1) Though I'm not sure why that is either...

Do you have a ~/.emacs or ~/_emacs.el file?  See
http://www.gnu.org/software/emacs/manual/html_node/emacs/Find-Init.html#Find-Init
and
http://www.gnu.org/software/emacs/manual/html_node/emacs/Init-File.html
for the details of emacs initialization.

Best regards
Robert



reply via email to

[Prev in Thread] Current Thread [Next in Thread]