[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] org-file using tramp + babel?

From: Charles C. Berry
Subject: Re: [O] org-file using tramp + babel?
Date: Thu, 14 Jan 2016 19:33:41 -0800
User-agent: Alpine 2.20 (OSX 67 2015-01-07)

On Thu, 14 Jan 2016, John Kitchin wrote:

Hi, I opened an org file using tramp on a remote server. It opened fine,
and I had no trouble writing text and saving it. For fun I tried running
a src block (a shell block that just returned the hostname), and got
this error:

tramp-file-name-handler: Couldn't write region to
decode using `base64 -d -i >%s' failed

Should this have worked? It looks like it tried to write a local path
from my Mac to the server, and that path doesn't exist there.

This works for me from my mac on a remote Centos system.

I think this tripped me up in the past, but my notes do not reveal the fix I used.

I think this is a temporary-file-directory issue, but nothing in my init pertains to that variable or tramp.

In my emacs-init.org, I do have

#+BEGIN_SRC emacs-lisp
(setq default-directory "/Users/cberry/")

and I see a lot of references to this in tramp-compat.el. So, maybe setting it is enough to get emacs and/or tramp to use my local client for temp files.

In *Messages* I see this after running the src block:

--8<---------------cut here---------------start------------->8---
Evaluate this shell code block on your system? (y or n) y
executing Shell code block...
Tramp: Encoding local file 
`/var/folders/kb/2hchpbyj7lb6z76l0q73w_fh0000gn/T/tramp.560h4h' using 
Tramp: Decoding remote file `/scp:<me at remote host>:/tmp/ob-input-560Uub' using 
`base64 -d -i >%s'...done
Tramp: Encoding local file 
`/var/folders/kb/2hchpbyj7lb6z76l0q73w_fh0000gn/T/tramp.5607Mu' using 
Tramp: Decoding remote file `/scp:<me at remote host>:/tmp/ob-error-560uCo' using 
`base64 -d -i >%s'...done
...<and more cycles like that>
--8<---------------cut here---------------end--------------->8---

and when I issue `C-h v temporary-file-directory RET' in the buffer of the 
remote file,
I get the same `/var/folders/...' which is what `echo $TMPDIR' shows locally.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]