[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] ob-julia, src block execution undefined function org-babel-get-heade

From: Andreas
Subject: [O] ob-julia, src block execution undefined function org-babel-get-header
Date: Thu, 21 Jan 2016 23:55:46 +0100

Hi list,
I was hoping to get some help with this issue

I use:
Org-mode version 8.3.3 (release_8.3.3-468-gf3f4b2)
GNU Emacs (x86_64-pc-linux-gnu, GTK+ Version 3.16.7) of 2016-01-17
ess-version: 15.09-2 patched [git: 6d05ba7c89371764c43e30a436d7166417cabd4d]
julia version 0.4.2

I'm trying to execute julia code src blocks but have come across a problem.

When trying to do C-c C-c in the src block emacs complain about an undefined function org-babel-get-header.
I think I have tracked down the error to ob-julia where org-babel-get-header is used.
I found a reference to a similar problem for ob-html package here: https://github.com/zweifisch/ob-http/issues/12
I tried to edit the ob-julia file based on that fix but failed to make it work.

I should also mention that a similar issue was covered in a previous thread but the info in this thread https://lists.gnu.org/archive/html/emacs-orgmode/2015-11/msg00426.html
I can't apply to my problem as there is only one ob-julia.

This looks like an issue in ob-julia, unless I overlooked something in my setup.
I tried running the same setup with a fresh emacs -q -l init.el loading only
Org-mode version 8.2.10 (release_8.2.10 @ /usr/share/emacs/25.1.50/lisp/org/)
which is bundled with my emacs
and the ess package
and I could evaluate julia src blocks with that setup.

Any advice or fixes I could apply would be appreciated, or if this issue can be fixed elsewhere.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]