[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] Org is exporting to tex an asterisk between "section" and "{"

From: Eduardo Mercovich
Subject: [O] Org is exporting to tex an asterisk between "section" and "{"
Date: Fri, 04 Mar 2016 16:15:31 -0300
User-agent: mu4e 0.9.17; emacs 24.5.1

Hello evoryone.

Troubleshooting a lack of ToC content in a exported PDF from org, I
found this issue.

Please forgive me if it's inaccurate. But I tried searching the web,
some org and latex lists and my local .emacs configuration and didn't
found anything related, so it must be a local issue or it would have
been reported before. 

Starting with a simple org file like this:

--8<---------------cut here---------------start------------->8---
* Section A, level 1
** Section AA, level 2
Some AA text. 
** Section AB, level 2
Some AB text. 
* Section B, level 1
** Section BA, level 2
Some BA text. 
** Section BB, level 2
Some BB text. 
--8<---------------cut here---------------end--------------->8---

and exporting to latex as latex file (C-c C-e l l), gives me:

--8<---------------cut here---------------start------------->8---


\section*{Section A, level 1}
\subsection*{Section AA, level 2}
Some AA text. 
\subsection*{Section AB, level 2}
Some AB text. 
\section*{Section B, level 1}
\subsection*{Section BA, level 2}
Some BA text. 
\subsection*{Section BB, level 2}
Some BB text. 
--8<---------------cut here---------------end--------------->8---

Please note the asterisks between section and it's next {.

In short, Org exports this:

instead of this:

Of course, it breaks the syntax (as I understood it, I'm new to latex)
and messes up the latex to pdf transformation, at least with the 2
classes I tried (standard article and tufte-handout).

I'm running
+ GNU Emacs 24.5.1 compiled on 2015-11-09
+ Org-mode version 8.3.1 (8.3.1-95-g1dbb25-elpaplus @

I have nothing in my .emacs that sounds related to latex or latex export
except the tufte-latex classes declarations. 

The packages I have enabled are:
+ org-bullets-20140918.1137
+ helm-mu-20151019.944
+ helm-core-20150831.933
+ helm-20151117.2303
+ org-caldav-20150131.152
+ google-maps-20130412.230
+ calfw-20150831.1847
+ calfw-gcal-20120111.200
+ async-20150818.1154
+ table-20140721.2215
+ pdf-tools-20150716.643
+ let-alist-1.0.4
+ mu4e

Does anyone suffered something similar? Is there more information I can
provide to troubleshoot the root of this export issue? 

In every case, thank you very much. :)


eduardo mercovich 

 Donde se cruzan tus talentos 
 con las necesidades del mundo, 
 ahí está tu vocación.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]