[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] Screenshot of agenda: agenda is not shown in time

From: Karl Voit
Subject: [O] Screenshot of agenda: agenda is not shown in time
Date: Wed, 13 Apr 2016 22:42:22 +0200
User-agent: slrn/pre1.0.0-18 (Linux)


I'd like to get a screenshot (PNG) of an agenda of mine by following

(defun my-export-month-agenda-to-png-via-screenshot()
  (org-agenda nil "n") ; generates agenda "n" (one month without todos)
  (if (my-buffer-exists "*Org Agenda*")
  (switch-to-buffer "*Org Agenda*")
  (message "Waiting for Screenshot ...")
  (sleep-for 1)
  (message "Say cheese ...")
  (setq myoutput
        (shell-command-to-string "/usr/bin/import -window root 
  (message (concat "Screenshot done (" myoutput ")"))

The code works somewhat: the corresponding agenda is generated, a
screenshot (via imagemagick) is created. But: on the screenshot, I
see the buffer from where I invoked
my-export-month-agenda-to-png-via-screenshot in the first place and
in the minibuffer I can read "Say cheese ...".

Therefore it seems to be the case that basically the function
changes to the newly created Agenda buffer *after* the screenshot
and probably after the end of the function.

As you can see, I tried to change to the agenda buffer «manually»
via switch-to-buffer with no change of the result. I even tried to
get the result I am wishing for by adding a one-second sleep phase
which should cancel out any buffer-switch-performance-delay.

Can you help me, what is going on here?

mail|git|SVN|photos|postings|SMS|phonecalls|RSS|CSV|XML to Org-mode:
       > get Memacs from https://github.com/novoid/Memacs <

https://github.com/novoid/extract_pdf_annotations_to_orgmode + more on github

reply via email to

[Prev in Thread] Current Thread [Next in Thread]