[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] Problems with M-<up> on Emacs 25.

From: Ian Barton
Subject: [O] Problems with M-<up> on Emacs 25.
Date: Sun, 17 Apr 2016 10:57:20 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

I think that this is an Emacs not org-mode problem, but maybe somebody
can throw some light on it.

On my computer running 24.5.1 M<up> works as expected. However, on
emacs I get:

Debugger entered--Lisp error: (error "There is no other window")
  funcall-interactively(scroll-other-window-down nil)
  call-interactively(scroll-other-window-down nil nil)

However, in my org buffer:

c-h w org-metaup
org-metaup is on <M-up>

which seems to indicate that the key is correctly bound.

If I start emacs with a minimal config that just has (require
org-mode), I still get the error.

I then tried the "If it doesn't work hit it with the biggest hammer
available" approach:

(require 'org)
(require 'ob-tangle)
(eval-after-load "org"
      (define-key org-mode-map (kbd "M-<down>") 'org-metadown)
      (define-key org-mode-map (kbd "M-<up>") 'org-metaup)))

but emacs thinks that M-<up> is bound to scroll other window.

Best wishes,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]