[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] How to use org mode shell with ssh?

From: Xi Shen
Subject: Re: [O] How to use org mode shell with ssh?
Date: Thu, 22 Sep 2016 12:37:38 +0000

Instead of using ssh, I tried with scp. This time I got a different error.

#+BEGIN_SRC shell :dir /scp:openwrt:/mnt/sda1
ls -al

The error, I think, is from the remote end.

/bin/sh: /bin/zsh: not found

Clearly, I am using zsh on my Windows, but my remote OpenWRT system only has ash installed. Is there's way to specify the shell to use on the remote end?

On Thu, Sep 22, 2016 at 8:15 PM Xi Shen <address@hidden> wrote:

I just tried with:

#+BEGIN_SRC shell :dir /ssh:openwrt:/mnt/sda1
ls -al

But still got the same error. I wonder on which end threw me this error. Maybe it is because I am using Emacs on Windows, and some thing is missing? Or maybe it is because the remote system is OpenWRT which has limited function?

On Thu, Sep 22, 2016 at 4:57 PM Colin Baxter <address@hidden> wrote:
On Wed, Sep 21 2016, William Denton wrote:

> On 22 September 2016, Xi Shen wrote:
>> #+BEGIN_SRC sh :dir /sshx:openwrt:/mnt/sda1
>> ls -al
>> #+END_SRC
> Just use ssh, not sshx, and it should work.
> Bill

In babel it is now (shell . t). The form (sh . t) is depreciated as from
org-mode version 8.2.10 at least.

Best wishes.

David S.


David S.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]