[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] Cask-initialize messes up org table manipulation commands

From: Heikki Lehvaslaiho
Subject: Re: [O] Cask-initialize messes up org table manipulation commands
Date: Sat, 1 Oct 2016 10:08:17 +0300

Thanks for suggestions, Adam.

I had not realised that the bug-hunter package can do interactive tests. I used it now and got the same result: the problem is caused by the (cask-initialize) _expression_.

As far as I understand, cask-initialize only collects the directory locations and dependencies of packages as a struct that is then processed later during the emacs start-up. How that can mess up the org cursor movement is a complete mystery to me.

I am using org mode and use-package to maintain, launch and configure my packages. The culprit can not be the tangling process nor the launching of the packages because they happens after cask is initialized (and bug-hunter works on elisp file, only).

I did try emacs with the -q but did not see any difference to -Q.

The one piece of information that I did not include in my posting: My emacs comes from homebrew git HEAD and is installed it with:

brew unlink emacs
brew uninstall emacs
brew install emacs --HEAD --use-git-head --with-cocoa --with-gnutls --with-rsvg --with-imagemagick
brew linkapps

Maybe I should try raising an issue for cask (https://github.com/cask/cask).



Heikki Lehväslaiho - skype:heikki_lehvaslaiho cell: +358 40 850 6640

On 29 September 2016 at 06:53, Adam Porter <address@hidden> wrote:
Heikki Lehvaslaiho <address@hidden> writes:

> The cell content disappears but to my surprise the cursor jumped out
> of the table! Trying with different tables, it came clear that the
> cursor always jumped one line down and left of the table). (Under the
> left border if you have a box cursor.) That should not happen!

This may not be much help, because I'm still using Org 8.2.4, but I
tried and was unable to reproduce this; the cursor remains in the table.

> The final twist to this story is that if I start emacs, create an org
> buffer with a table, and run org-table-cut-region key combination
> first before evaling the init.el content, the cursor behaviour does
> not change even after cask has been initialized!

You said you bisected your init file; I assume you used the bug-hunter
package?  If by chance you did it manually instead, I would recommend
doing it again with bug-hunter; maybe you made a tiny mistake that threw
the whole thing off.  :)

Since it doesn't happen with "emacs -Q", I guess it must be someting in
your config.  (Though you might test with "emacs -q" also--there is a

I don't use Cask, so I can't help you much there.  What follows is what
may be considered an unhelpful suggestion, but it's the best idea I
have: switch from Cask/Pallet to use-package; it may give you
finer-grained control over your init file, and bisecting may work
better.  I don't know remember how Cask works exactly, but if
cask-initialize "monolithically" loads all the packages you have
configured, I'm guessing you won't be able to bisect within it to figure
out which package is causing the problem.

Hope this helps.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]