[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] org-agenda-filter-effort and "invalid face reference"

From: wtm
Subject: [O] org-agenda-filter-effort and "invalid face reference"
Date: Sun, 1 Jan 2017 16:00:53 -0600


I'm having trouble using org-agenda-filter-by-effort on existing
agendas in orgmode 9.0.3 in GNU Emacs 25.1.1 ([x86_64-w64-mingw32] of
2016-09-17).  Each time I attempt to use org-agenda-filter-by-effort,
I type "_" and then "=" and I select the one-digit index of the effort
estimate I want--in my case, I select "3" which corresponds to "0:30".

Instead of seeing only those orgmode TODO headings that have an effort
property of "0:30" in the agenda buffer as I would expect, all the
TODO headings disappear.  However, every other type of filter on the
agenda buffer seems to work.  I can easily filter by category and tag.
I have attempted this with my configuration and without any custom
configuration at all and always gotten the same result.

Although no errors occur (at least none that M-x toggle-debug-on-error
pick up) the *Messages* buffer provides some feedback: "Invalid face
reference: org-agenda-filter-effort [2 times]".

I've tried searching for information about the "invalid face
reference" message and orgmode.  I've found a few discussions on the
orgmode listserv, one of them that occurred recently (November 4,
2016).  However, the version of orgmode in this most recent discussion
is 8.3 and I'm using orgmode 9.0.3.  And it appears that the patch
described has already been applied.  I also inspected org-agenda.el
for the changes and they appear to be there (although I'm not a very
experienced elisp programmer or debugger).

[O] [PATCH] org-agenda.el Correct :inherit on org-agenda-fontify-priorit

[O] `invalid face reference nil` caused by `org-agenda-fontify-propertie

[O] Bug: Priority #B in Agenda causes invalid face reference [8.2.1 (8.2

I've attempted to reproduce the problem in Emacs 25.1.1 and orgmode
9.0.3 without any configuration and still experienced the same
problem.  To reproduce the problem I think you'd only need to create
an org file, add an entry with a TODO heading, and then assign an
effort estimate that corresponds to the array of allowed values (see
description of org-agenda-filter-by-effort http://bit.ly/2iF4o68).
After that, you'd need to create an agenda by entering "C-c a"
(org-agenda) and "t" (List all TODO entries).

I'm at a loss as to what steps to attempt next to troubleshoot this.
I've seen an intriguing discussion on Stack Exchange about "font lock
studio" but I couldn't get it to work.  I'd appreciate any tips you
might have on how to proceed.

Thanks and Happy New Year to all my fellow org-mode users!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]