[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] Org release_9.0 hangs

From: Martin Zuther
Subject: Re: [O] Org release_9.0 hangs
Date: Wed, 18 Jan 2017 20:23:44 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1


My message from two weeks ago ("[O] Possible bug: Emacs hangs on (require 'org)") seems to have missed attention, so here it is again.

About every third time I start Emacs, I also experience a very slow startup with org-mode 9.0.3 enabled. I run "GNU Emacs 24.5.1 (x86_64-pc-linux-gnu, GTK+ Version 3.18.9) of 2016-04-17 on lgw01-04, modified by Debian" on Linux Mint 18.1 Cinnamon.

Here is my minimal setup:

  ;;; Minimal setup to load latest 'org-mode'

  ;; activate debugging
  (setq debug-on-error t
            debug-on-signal nil
            debug-on-quit nil)

  ;; add latest org-mode to load path
  (add-to-list 'load-path "~/.emacs.d/elisp/org_9.0.3/lisp")
  (require 'org)


  Possible bug: Emacs hangs on (require 'org)

to the end of this setup file doesn't change anything.

This bug is solved by disabling my network, but in contrast to Luke , I have access to a fast and stable network.

Normal startup time is below one second. When the bug hits, it is around 2 minutes and 7 seconds, which to me looks suspiciously like a typical network timeout of 120 seconds.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]