[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] `:wrap src latex' now fails on export

From: Nicolas Goaziou
Subject: Re: [O] `:wrap src latex' now fails on export
Date: Mon, 25 Dec 2017 00:16:17 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (gnu/linux)


"Berry, Charles" <address@hidden> writes:

> I can execute this src block with no problems:
> #+begin_src emacs-lisp :wrap src latex :exports results
> "some-text"
> #+end_src
> and it will produce the expected result:
> #+begin_src latex
> some-text
> #+end_src
> and if I then export as (say) `C-c C-e C-b l L n y', I get just `some-text' 
> in the LaTeX buffer.
> But if I try to execute the first block, i.e. `C-c C-e C-b l L y'
> I get an error *before* the prompt for the latex src block appears and
> this in my *Message* buffer :
> ,----
> | org-babel-exp process emacs-lisp at position 3...
> | Evaluate this emacs-lisp code block on your system? (y or n) y
> | executing Emacs-Lisp code block...
> | Code block evaluation complete.
> | org-babel-exp process latex at position 14...
> | org-babel-exp-process-buffer: Wrong type argument: integer-or-marker-p, nil
> `----
> I've tried edebug-ing and got as far as `org-babel-exp--at-source',
> but haven't been able get any further.

Your initial block generates a new source block, that the export process
has to evaluate. Unfortunately, Org assumes all source blocks to be
evaluated are located within the original buffer. Since it can find the
newly generated one, it returns an error.

I fixed it in maint.


Nicolas Goaziou

reply via email to

[Prev in Thread] Current Thread [Next in Thread]