[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LaTeX export failure

From: Thomas S. Dye
Subject: Re: LaTeX export failure
Date: Wed, 29 Jan 2020 15:22:47 -1000
User-agent: mu4e 0.9.18; emacs 26.3

Thanks John,

IIRC, this isn't the first time you've recommended that I divide and conquer :)

Here is the offending bit, which worked fine last November but fails today:

#+caption: Compare figure\nbsp{}[[fig:mqs3_op]].

All the best,

John Hendy writes:

On Wed, Jan 29, 2020 at 2:32 PM Thomas S. Dye <tsd@tsdye.online> wrote:

Happy New Year!

Returning to a writing project after a few months absence, I'm no longer able to export the writing project subtree. Here is what I
find in *Messages*:

  Wrote /home/dk/Projects/historical-inference/r14c.org
  executing Shell code block...
  Wrote /tmp/babel-j0SOWm/ob-input-aS23DO
  Code block evaluation complete.
match-string-no-properties: Args out of range: #<killed buffer>,
  3, 11

Are you able to share a portion of this? Or have you tried, say,
creating a copy of the file and removing all but the first heading and
a sentence to see if it fails?

Someone else might recognize that particular failure from past
experience, but I'd have to try something locally. In the past to debug I've moved all headings after the first under a new one, marked that as :noexport:, and exported iteratively, moving each one out of the :noexport: heading until I find the offending one. Then I can hone
in on where I should be looking.


The writing project exported without issue on November 7, 2019.

I'm typically using up-to-date org-plus-contrib from Elpa, so
suspect my issue is due to a recent change in Org mode.

I don't know how to track down the problem.  Any ideas?

All the best,
Thomas S. Dye

Thomas S. Dye

reply via email to

[Prev in Thread] Current Thread [Next in Thread]